
Retouching Photographs for the Web  

Healing Brush - What does it do?  

The Healing Brush is designed to help you remove flaws from an image, such as 

scratches in a photo or age lines in a person's face. You essentially paint the flawed area 

with pixels that you pick up from another part of the image. For example, if a person has 

wrinkles at the edges of his or her eyes, you can sample an area of skin on the forehead 

that has no such flaws. When you paint over the wrinkles, you cover the blemish. The 

Healing Brush uses the texture of the sampled area and applies the tonal characteristics of 

the area around the flaw. You need to sample an area with the same basic color as the 

area around the flaw, but you needn't worry about matching the color exactly. The 

Healing Brush has the ability to blend to the area you're painting. 

Healing Brush - Follow these steps  

Select the Healing Brush from the Toolbar palette. The Healing Brush icon looks like a 

bandage. Then follow the steps below.  

1. Identify the flaw.  

2. Identify an area near the flaw that looks similar to the area with the flaw. This 

nearby area is the area you will sample.  

3. Hold down Option (Macintosh) or Alt (Windows) and click in the area you want 

to sample.  

4. Click and drag to paint over the flaw.  

Healing Brush - Overview of Settings  

When the Healing Brush is selected, the Options bar at the top of the screen allows you to 

alter the way the tool works. These options both alter the way you use the tool, and help 

you to address specific needs more effectively.  

Tool Presets Picker 

Once you've set any tool the way you like it, you can save the settings as a named tool 

preset , and then reuse those settings with a click of the mouse. (It really beats trying to 

remember a group of options that you liked.) To use a tool preset, simply set the options 

on the Options bar the way you like, open the Tool Presets panel, and click the New Tool 

Preset button. Provide a name, and you've created a preset that you can use anytime you 

work in Photoshop.  

Brush  

When you paint with any tool in Photoshop, you need to choose a brush. Click the brush 

option to select a brush size, shape, and hardness for the tool.  



Mode  

The mode determines how the pixels you paint with interact with the pixels you paint 

over. Any time you mix pixels, you can set the mode.  

Source  

Although you'll most often paint with pixels you've sampled, you can also paint with a 

pattern you've created. This can be useful in cases where you don't have an area to sample 

in the existing image; sometimes you can create a pattern that matches the area you need 

to repair. Then select the pattern from the pop-up menu of saved patterns.  

Aligned  

This is an on/off switch to determine the starting position of the sample point. With this 

option selected, the sample point stays the same relative distance from the area you're 

painting-no matter where you paint. With Aligned turned off, the sample always starts at 

the place where you pressed Option or Alt and clicked. We'll come back to this later as a 

strategy for dealing with specific problems.  

Healing Brush - Choosing a Brush  

Choosing a brush for healing starts with the size of the brush. Generally, you should 

choose a brush that's about twice the size of the blemish at its widest point. Most 

scratches are pretty thin; if you make the brush too wide, you'll have a hard time keeping 

the sample area from drifting onto pixels that don't match the area you're trying to fix.  

Another brush setting to consider is the hardness of the brush. When painting with any 

tool, you'll normally use a soft-edged brush to create a smooth transition at the edges of 

the painted area. The Healing Brush generally works the same way; a softer edge can 

hide the effect of the brush.  

Healing Brush - Using Replace Mode  

Sometimes the smoothing effect of the Healing Brush creates an unnaturally smooth line 

around the painted swath. To avoid this problem, use the Replace mode from the Options 

bar. This turns off the smoothing effect normally employed by the Healing Brush tool. 

This is especially useful for areas with a lot of fine, random detail such as a sandy beach 

or a photograph with visible film grain.  

Healing Brush - Using Other Modes  

For more subtle corrections, such as age lines or watermarks, try the other modes. These 

modes use various mathematical formulas to combine the pixels you're painting with the 

pixels you're covering. The effect will be a more blended correction that will keep the 



detail from the original. However, my testing of the other modes has produced little in the 

way of effective flaw correction; you probably can stick with Normal and Replace modes 

for most of your work.  

Healing Brush - Using a Non-Aligned Sample Area  

In some cases, you may only have a small area to use for the sample. This will require 

you to click and drag in several small corrections instead of one long painting motion. By 

deselecting the Aligned option, you can paint with the same small sample area, because 

each time you click the mouse to paint, the starting point of the sample will return to the 

place where you initially clicked with Option or Alt. Just keep an eye out for any 

repetitive patterns created by overuse of this technique.  

Healing Brush - Using another Photo or Image  

Sometimes you just can't find a good sample source in an image. All is not lost. In these 

cases, you can open a second image and sample it. Here's how:  

1. Open the two images in Photoshop.  

2. Select the Healing Brush tool.  

3. Click the image you want to sample to bring it forward, hold down Option (Mac) 

or Alt (Windows), and click to sample an area.  

4. Click the image needing repair to bring it to the front.  

5. Click and drag to paint as you normally would.  

There are a couple of things to note. First, both documents must be set to the same color 

mode. If not, Photoshop will complain and refuse to allow you to paint. Also, it's a very 

good idea to set the windows apart so that you can see both documents as you paint. If 

you don't, you might drift into sample areas that don't match the area of the flaw.  

Healing Brush - Using a Pattern  

Some images have a large area of essentially random-looking detail. A sandstone wall, 

for example, has a sea of little specks. If you need to touch up a lot of specks or scratches 

in such an image, you can save some time by using a pattern.  

1. Use the Rectangular Marquee tool (hint: press m ) and select an area of detail with 

no flaws in it.  

2. Constrain the rectangle to a square by holding the Shift key while you drag with 

the Marquee tool.  

3. Choose Edit, Define Pattern to create a pattern from the selection. Give it a 

descriptive name.  

4. Select the Healing Brush tool and set the source to Pattern on the Options bar.  

5. Choose the new pattern from the Pattern pull-down menu.  

6. Paint over the flaws.  



One thing to watch for is the tiling effect you can see if you paint over large areas with a 

pattern. To avoid this error, turned off the Aligned option and paint with small clicks to 

"dab" paint instead of producing large swaths  

The Patch Tool  

The counterpart to the Healing Brush tool is the Patch tool. It uses the same techniques as 

the Healing Brush, but is designed to help remove large patches of trouble, such as specs 

and dust on a photo. It's a much simpler tool to use, and that fact is reflected in the 

options available for the tool.  

To use the Patch tool, begin by selecting an area in your image. By default, the tool is set 

for you to encircle the blemish and then click-and-drag over an area that has the texture 

you want to use as replacement. When you let go, the area you're repairing will be 

replaced by the texture of the pixels onto which you dropped the patch.  

Patch Tool - Options  

There are only two sets of options available with the Patch tool. The first determines the 

overall behavior of the tool. Source sets the tool to act as described previously. 

Destination reverses the behavior of (and the way you will use) the tool. With Destination 

selected, you encircle an area of the image to use as the repair. Once it's encircled, grab it 

and drop it onto the damaged area. The effect is the same, so it's up to you which method 

you use.  

The Pattern option enables you use a pattern to fill an area. Because the pattern's texture 

takes on the tone and hue of the area you're repairing, you can fix areas that have no 

similar areas available. It works best in cases where the flaws are in an area that has 

random detail.  

Patch Tool - Working with the Patch Selection 

 Hide the selection. The marquee makes it difficult to see the effect-especially at 

the edges (which is where you're most likely to see trouble). A simple method for 

dealing with this problem is to use the Extras function from the View menu. 

Command or Alt+H will toggle the visibility of the selection on or off. The area 

remains selected; it's just hidden, which makes it easier to see the area in the 

context of its surroundings.  

 Shift+select. As with any other selection tool, holding down the Shift key while 

selecting with the Patch tool adds to the selection area. If you have several small 

blemishes in an area, you can Shift+select them to get them all in one shot.  

 Option-select (Mac) or Alt+select (Windows). This technique allows you to 

carve hunks off the selection. Sometimes you may grab too much of an image 

with the Patch tool. Simply hold down Option (Mac) or Alt (Windows) while 

clicking and dragging with the Patch tool. This will deselect areas of the image 

that are currently selected.  



Optimizing Photographs for the Web  

Add contrast to a photo using the Brightness/Contrast command.  

The Brightness/Contrast command lets you increase the difference between the bright 

and dark areas of a photo, which in turn lets you see more detail and often makes the 

photo more realistic.  

 In the Layers palette, select the layer containing the image you want to change.  

 Choose Image > Adjustments > Brightness/Contrast. Arrange the 

Brightness/Contrast dialog box so that you can see as much of the image as 

possible.  

 In the Brightness/Contrast dialog box, make sure Preview is selected.  

 Drag the Contrast slider to the right to increase contrast. Drag the Brightness 

slider to the right to increase Brightness.  

 When you are satisfied with the adjustment, click OK.  

*You can make all contrast adjustments on an adjustment layer, rather than 

directly to the image. Isolating your adjustments on a separate layer lets you 

experiment with the image without altering its actual pixels. Because the settings 

are on a separate layer, you can view the image with and without the adjustment 

by clicking the adjustment layer's eye icon. To adjust the contrast on a separate 

layer, choose Layer > New Adjustment Layer > Brightness/Contrast.  

Crop, straighten, or rotate a photo using the Crop tool.  

 Increase the size of the document window so that you have some space around the 

photo. (Position the pointer on the bottom right corner of the document window. 

When the pointer changes to a double-headed arrow, drag.)  

 Select the Crop tool in the toolbox.  

 In the options bar at the top of the work area, make sure Width, Height, and 

Resolution contain no values. These settings constrain the dimensions of the crop 

rectangle. If necessary, click the Clear button to clear them.  

 Drag over the part of the photo that you want to keep. To straighten or rotate the 

photo, drag the cropping rectangle over the entire photo.  

 If necessary, adjust the cropping rectangle as follows:  

o To adjust the size of the cropping rectangle, drag a corner or side handle.  

o To nudge the cropping rectangle slightly, press an arrow key.  

o To move the cropping rectangle to a new location, place the cursor inside 

the cropping rectangle and drag it to the new location.  

o To rotate or straighten the area, move the pointer outside the cropping 

rectangle (the pointer becomes a curved double-arrow) and drag. The 

cropping rectangle rotates, but the image remains stationary until you crop 

it. You may need to reposition and resize the selection box.  



Note: If the cropping rectangle is hard to adjust because it sticks or seems to jump 

to set locations, make sure the Snap option on the View menu is not enabled. A 

check mark indicates the option is on. Choose View > Snap to turn off the option.  

 When you are satisfied with the size and location of the cropping rectangle, press 

Enter (Windows) or Return (Mac OS) to crop the photo. If you rotated or 

straightened the cropping rectangle in the previous step, the photo will adjust to 

the angle you selected. 

Lighten or darken a photo using the Levels dialog box. 

You can lighten or darken a photo using the Levels dialog box. The Levels dialog box 

displays a graph, called a histogram , which depicts the tonal range of an image. Images 

with poor tonal ranges, such as underexposed and overexposed images, result in fairly 

low and flat histograms. On the other hand, an image with a good range of darks and 

lights generates a deeper, more varied histogram. Using the histogram as a guide, you can 

adjust the tonal balance of an image.  

 In the Layers palette, select the layer containing the image you want to change.  

 Choose Image > Adjustments > Levels. Arrange the Levels dialog box so that the 

you can see as much of the image as possible.  

 In the Levels dialog box, drag the black Input Level slider (on the left of the 

histogram) so that it aligns with the leftmost cluster of pixels in the histogram. 

This maps the darkest pixels in the image to black. (If the pixels are clustered on 

the left edge of the histogram, you don't need to move the black Input Level 

slider.)  

 Drag the white Input Level slider so that it aligns with the last cluster of pixels on 

the right end of the histogram. This maps the lightest pixels in the image to white. 

(If the pixels are clustered on the right edge of the histogram, you don't need to 

move the white Input Level slider.)  

 Drag the gray Input Level slider either to the left to lighten the image or to the 

right to darken the image. Although this seems counterintuitive, by moving the 

gray slider to the left, for example, you map the mid tones of the image to a 

darker shade while increasing the range of the light tones.  

 When you are satisfied with the image, click OK.  

*You can make all color adjustments on an adjustment layer, rather than directly 

to the image. Isolating your adjustments on a separate layer lets you experiment 

with the image without altering its actual pixels. Because the settings are on a 

separate layer, you can view the image with and without the adjustment by 

clicking the adjustment layer's eye icon . To create an adjustment layer, choose 

Layer > New Adjustment Layer > Levels.  

Lighten or darken an area in a photo using the Dodge or the Burn tool.  

 In the Layers palette, select the layer containing the image you want to change.  



*To protect other areas of the image from change, you can create a selection 

marquee around the area you want to lighten or darken. The Dodge and Burn 

tools will affect only the area within the selection marquee. To soften the edge of 

the selection so the changes you apply blend in more naturally with the unselected 

areas, use the Feather command (Select > Feather).  

 To lighten an area and bring out the highlights, select the Dodge tool in the 

toolbox. To darken an area, select the Burn tool in the toolbox.  

 In the options bar at the top of the work area, open the Brush pop-up palette by 

clicking the arrow next to the current brush. Choose a soft-edged brush preset 

from the palette. Make sure the brush diameter is smaller than the area you want 

to change.  

 Set Range in the options bar to control the focus of the tool: Mid tones to change 

the middle range of grays (the standard choice), Shadows to change the dark areas, 

and Highlights to change the light areas.  

 Set Exposure to around 50%.  

 Drag over the area you want to change.  

Sharpen a photo using the Unsharp Mask filter.  

 In the Layers palette, select the layer containing the image you want to change.  

*If you want to sharpen only a specific element or area in the image, create a 

selection marquee around the area you want to sharpen using the selection tools. 

The selection marquee limits the changes to that area. To soften the edge of the 

selection so the changes blend in more naturally with the unselected areas, use the 

Feather command (Select > Feather).  

 Choose Filter > Sharpen > Unsharp Mask.  

 In the Unsharp Mask dialog box, make sure Preview is selected. Then position the 

Unsharp Mask dialog box so that you can see most of the image.  

 Drag the Amount slider to the right to increase the contrast of the edge. For high-

resolution printed images, an amount between 150% and 200% is usually 

satisfactory. Grainy images usually require a lower setting.  

 Drag the Radius slider to the right to increase the width of the edge created by 

sharpening. If you set this too high, the edges will acquire obvious halos. A 

setting between 1 and 2 is often adequate.  

 Drag the Threshold slider to the right to increase the difference needed between 

shades before the filter sharpens the edge between them. A threshold of zero 

sharpens all pixels in the image. A high threshold number sharpens the edges only 

between significantly different shades. Values between 2 and 20 are usually 

acceptable.  

 Experiment with these three controls until you are satisfied with the results, and 

then click OK.  



*You can let Photoshop sharpen the image for you using the three other Sharpen 

filters. Choose Filter > Sharpen, and then choose one of these filters from the 

submenu: Sharpen, Sharpen Edges, or Sharpen More.  

Resize and optimize an image for the Web using the Save for Web 

dialog box in Photoshop.  

When you save an image for the Web, you must balance maintaining image quality with 

minimizing file size and thus download time. The Save for Web dialog box lets you 

preview different optimization settings. Each preview includes file size and estimated 

download time. Thus, without altering the original image, you can see the results of 

various settings and choose the setting that best meets your needs.  

 Open the image in Photoshop, and choose File > Save for Web.  

 In the Save for Web dialog box, click the 4-Up tab. The dialog box displays the 

original image and three previews using different optimization settings.  

 Click a preview to select it, and then choose a file format preset from the Preset 

pop-up menu to see the difference in quality. Repeat as needed for each preview. 

Choose presets based on the file format appropriate for your image:  

o JPEG for continuous tone images, such as photographs. JPEG 

compression preserves a broad range of color and subtle variations in 

brightness, but does not support transparency.  

o GIF for animations, solid-color images, and images with repetitive color, 

such as line art and logos. GIF supports transparency.  

o PNG-8 for solid-color images with sharp detail. Note that many older 

browsers do not support the PNG format.  

o PNG-24 for continuous tone images, such as photographs. PNG-24 

preserves transparency, a broad range of color, and subtle variations in 

brightness. Note that many older browsers do not support the PNG format.  

 Choose 200% from the zoom pop-up menu at the bottom left corner of the dialog 

box. Zooming in lets you examine the detail in each of the previews.  

 If you want to compare other areas of the image, click the Hand tool (on the upper 

left side of the dialog box) and drag the image. All the previews move together.  

 If you want to resize the image, click the Image size tab on the right side of the 

dialog box. Enter the desired dimensions for Width and Height. Click the Apply 

button in the tab. (When you save the file, Photoshop resizes only the Web-

optimized version.)  

 Select the preview that best meets your needs, and click Save.  

 In the Save Optimized As dialog box, locate the folder in which you want to save 

the image, type a name for the file, and click Save.  

Fix red eyes in photos using the Color Replacement tool.  

 In the Layers palette, select the layer containing the image you want to change.  

 Select the Zoom tool in the toolbox, and click the eyes you want to fix to zoom in 

closer.  



 Select the Color Replacement tool in the toolbox. It may be hidden by the Healing 

Brush tool or Patch tool .  

 In the options bar at the top of the work area, click the current brush to open the 

Brush pop-up palette. Move the Diameter slider to make the brush tip smaller than 

the area you are fixing.  

 Make sure the other controls in the options bar are set as follows:  

o Mode: Color  

o Sampling: Once  

o Limits: Discontiguous  

o Tolerance: 30%  

o Anti-aliased selected  

 Click the Swatches tab to bring the Swatches palette to the front or, if the palette 

isn't open, choose Window > Swatches.  

 In the Swatches palette, click the black color swatch to use as your replacement 

color. Replacing red eyes with black, the color of the pupil, works well for most 

photos. However, close-ups of light-colored eyes may require additional touching 

up to reduce the size of the pupil.  

 In the document window, click once on the red eye to set the target color you 

want to replace. Drag the brush over the red area until you have fixed the eye. If 

some areas remain red, click the red area again to reset the target replacement 

color, and drag over the remaining red areas. 

 


